:: News .:. Documents .:. Forum .:. Downloads .:. Bibliographie .:. Liens .:. Contact  :: 


Home
  :. News
  .: Documents
    .: Notions
    .: Protocoles
    .: Sécurité
    .: Architecture
    .: Prog
    .: Systèmes
  :. Forum
  .: Downloads
  :. Bibliographie
  .: Liens
  :. Contact

Chat

  Nickname:


irc: #guill.net

Forum



 
Comment se connecter à un Cisco 2500 ou 2600 ?  
 

 

I. Description du routeur CISCO 2500 ou 2600

A. Ses composants

IOS « Internetworking Operating System » CISCO 2500 : version 11.2(10)

ROM : Contient le « bootstrap » pour le démarrage du routeur.

NVRAM : Contient la configuration du routeur (suite d’instructions ASCII).

RAM : Contient les instructions (Routage - Filtres - NAT .. ) exécutées par le routeur dans sa phase opérationnelle.

FLASH : Contient l’IOS du routeur .

B. Interfaces de configuration et différents modes de fonctionnement

Pour se connecter à un routeur CISCO on peut utiliser plusieurs méthodes décrites dans cet article.

Les accès au routeur sont protégés par un mot de passe.

Le contrôle du routeur et sa configuration nécessitent l’exécution de commandes en mode UTILISATEUR, ou SUPERVISEUR. Le passage d'un mode à l'autre se fait grâce aux commandes "enable" et "disable"

Seul le mode "enable" permet de configurer le routeur.

Lorsque vous êtes connectés au routeur, la liste des commandes que vous pouvez effectuer est donnée en tapant "?".

II. Initialisation du routeur via le port "console"

1. Pour initialiser le routeur, connecter un PC via son port série au port "console" console du routeur. Utiliser la fonction émulation de terminal (Hyperterminal sous Windows), disponible sous Windows avec les caractéristiques de liaison suivantes :

- 9600 Bits/S
- 2 Bits de Stop
- 8 Bits/caractère
- Xon/Xoff
- Sans parité.

2. Mettre le routeur sous tension.

3. Se connecter en mode superviseur avec la commande « enable » et le password du routeur.

4. Configurer les @IP des interfaces du routeur, le protocole de routage et le password grâce à la commande « setup ».

5. Vérifier la configuration active en RAM : sh run

6. Vérifier la configuration chargée en NVRAM : sh configuration ou sh startup-config.

7. Vérifier la table de routage : sh ip route

8. Pour quitter le mode superviseur, entrer la commande : disable.

Autres commandes

- lecture de la configuration active (RAM) : show running-config
- lecture de la configuration mémorisée dans la NVRAM : show startup-config
- écriture de la configuration active dans la NVRAM : copy running-config  startup-config
- test de la configuration d’une interface IP : ping @IP

III. Modification de la configuration du routeur cisco

Une fois la configuration initiale du routeur réalisée, il est possible de la modifier de trois manières différentes :
- Par la console.
- Par le réseau.
- Par le RTC (Cette configuration nécessite le raccordement d’un modem sur le routeur).

A. Accès local (Console)

a - Passer en mode Superviseur ( enable ) puis en mode Configuration ( conf t ). Utiliser la commande « CTRL Z » pour quitter ce mode configuration.

Le prompt devient alors : Routeur-Name (config) &

b - Entrer ? pour visualiser les commandes accessibles dans ce mode.

c - Modifier l’adresse IP de l’interface Et0
Routeur-Name (config) & : interface et0
Routeur-Name (config-if) & : ?
Routeur-Name (config-if) & : IP ?
Routeur-Name (config-if) & : IP address @

d - Quitter le mode  configuration : CNTL Z

e - Vérifier la nouvelle configuration active : sh run

f - Sauvegarder la nouvelle configuration dans la NVRAM : wr mem ou copy running-config startup-config

g - Quitter le mode superviseur : disable

B. Connexion au routeur via le RTC

Maintenant, on va utiliser une transmission par modem pour se connecter à un routeur distant et ainsi modifier sa configuration. Une telle application peut être utile par exemple pour faire de la télémaintenance de réseau.

1. Connecter le modem au routeur à l’aide de l’adaptateur DB9-DB25.

2. Depuis la console configurer l’interface auxiliaire du routeur pour dialoguer avec le MODEM :

cisco_2>en
Password: cisco
cisco_2#conf t
cisco_2(config)#line aux 0
cisco_2(config)#transport input all
cisco_2(config-line)#speed 38400
cisco_2(config-line)#modem inout
cisco_2(config-line)#flowcontrol hardware
cisco_2(config-line)#^Z

3. A partir du PC, configurer le MODEM via le routeur par telnet afin de permettre au modem d’accepter les appels entrants :

TELNET @IP-Routeur 2001

Remarque :
2001 correspond au port de communication du routeur qui permet la configuration du modem pour le Cisco 2500. Pour le Cisco 2600, faire sh async line pour avoir la liste des ports utilisant une ligne asynchrone.

Dans le fenêtre du terminal saisir les commandes suivantes :

AT
( réponse OK)
AT&F
ATS0=2
ATB

Quitter le mode Telnet.

Le routeur est maintenant prêt à dialoguer avec le MODEM. Les LEDS RTS, CTS et DTR sont allumées.

4. Ouvrir une connexion vers le routeur sur le PC.

(a) Avec le PC dont le modem est connecté à l’autocommutateur de l’école, activer l’ HyperTerminal sous Windows, donner un nom de session (exemple: Routeur), puis cliquer sur « OK ».

(b) Choisir le modem, entrer le numéro de téléphone et cliquer sur « OK ».

On constate que le numéro est précédé de chiffres non vloulus.

(c) Cliquer sur « modifier ». Désactiver l'option "Utiliser le code du pays et l'indicatif".

Le numéro est maintenant le bon.

C. Accès distant : PC connecté à un segment ETHERNET

Principe

Ce mode de configuration permet de contrôler et de configurer le routeur depuis un poste de travail connecté à une interface ETHERNET du routeur.
Pour se connecter au routeur utiliser la commande :
telnet @IP_interface_routeur.

On peut alors réaliser :
- une configuration immédiate
- une configuration définie dans un fichier situé sur un serveur tftp.

Configuration immédiate

Passer en mode configuration grâce à la commande conf t.

Remarques :
Entrer ? pour obtenir la liste des commandes et CTRL Z pour quitter le mode configuration.

Configuration définie dans un fichier de configuration

Manipulation

1. Sur votre poste de travail activer un serveur tftp ( Application PumKin disponible gratuitement sur Internet )

2. Activer l’application telnet, pour se connecter au routeur en mode superviseur :

Telnet @IP Interface
password …

3. Pour copier la configuration active du routeur (en RAM) dans un fichier du serveur TFTP, entrer la commande :

write net

4. Le fichier précédemment sauvegardé peut être édité avec WORDPAD, modifié et ensuite transféré dans la mémoire du routeur par la commande :
conf net

5. Utiliser le fichier de configuration suivant pour modifier l’adresse IP de l’interface non utilisée pour les connexions TELNET et TFTP.

Exemple de fichier de configuration :

version 11.2
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router
!
enable password 7 104D000A0618
!
!
interface Ethernet0
 ip address 195.51.150.50 255.255.255.0
!
interface Ethernet1
 ip address 193.49.148.50 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 no ip address
 shutdown
!
no ip classless
!
line con 0
line aux 0
 transport input all
line vty 0 4
 password 7 104D000A0618
 login
!
end

 




Sondage

Quel est votre connexion à Internet aujourd'hui ?
 
RTC 56Kbps
ADSL simple de 128 à 2048 Kbps
ADSL + Téléphonie (+TV) de 128 à 2048 Kbps
ADSL simple jusqu'à 20Mbps
ADSL + Téléphonie (+TV) jusqu'à 20Mbps
Autres (RNIS, Satellites bi-directionnel...)
Total :
2653

Recherche


Docs
   Pflogsumm (Analyseur de log mail pour Postfix)
   Proftpd (Mise en service d'un serveur FTP avec proftpd sous Linux)
   Openldap (Mise en service d'un serveur LDAP sous Linux)
   Gestion des périphériques en c++ builder (Communication RS232 en C++ Builder)
   Les sockets windows (Windows Sockets : un cours accéléré)

guill.net©1999-2018